SSL probs, error "PEM_read_bio:no start line"

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

SSL probs, error "PEM_read_bio:no start line"

a.smith
Hi,

   I´m currently trying to install Ejabber 2 having had an ejabber 1.x  
server for a couple of years. However I cannot get SSL (TLS) to work,  
each time I try and connect to the server the sasl.log shows this error:

Reason:     {{badmatch,{error,"SSL_CTX_use_PrivateKey_file failed:  
error:0906D06C:PEM routines:PEM_read_bio:no start line"}},

The certificate I´ve installed is signed from our own internal  
certificate authority in the same way I´d do for apache etc. Can  
anyone help me out?

thanks in advance, Andy.
_______________________________________________
ejabberd mailing list
[hidden email]
http://lists.jabber.ru/mailman/listinfo/ejabberd
Reply | Threaded
Open this post in threaded view
|

Re: SSL probs, error "PEM_read_bio:no start line"

a.smith
Hi,

    ok, Ive managed to fix this now. Solution for me was to copy the  
SSL server key into the same file as the signed certificate.
ie

cat myserver.key >> mycert.pem

thanks, Andy.

Quoting Andy Smith <[hidden email]>:

> Hi,
>
>   I´m currently trying to install Ejabber 2 having had an ejabber  
> 1.x server for a couple of years. However I cannot get SSL (TLS) to  
> work, each time I try and connect to the server the sasl.log shows  
> this error:
>
> Reason:     {{badmatch,{error,"SSL_CTX_use_PrivateKey_file failed:  
> error:0906D06C:PEM routines:PEM_read_bio:no start line"}},
>
> The certificate I´ve installed is signed from our own internal  
> certificate authority in the same way I´d do for apache etc. Can  
> anyone help me out?
>
> thanks in advance, Andy.
>

_______________________________________________
ejabberd mailing list
[hidden email]
http://lists.jabber.ru/mailman/listinfo/ejabberd